We are experiencing issues with accessing the web application and the website
Incident Report for Signeasy
Resolved
This incident has been resolved.
Posted Feb 23, 2023 - 11:20 UTC
Investigating
Our DNS provider, GoDaddy is facing an outage with their DNS service. Due to this, our links and requests in the platform might be failing to resolve. We’re expecting this to be resolved shortly
Posted Feb 23, 2023 - 10:41 UTC
This incident affected: Web and Mobile Apps (Web Application, Android Application, iOS Application).