We are currently experiencing issues accessing all transactions and settings update on our platform.
Incident Report for Signeasy
Resolved
The incident has been resolved and all services are back in operation.
Posted Nov 30, 2023 - 06:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2023 - 06:08 UTC
Investigating
We are currently investigating this issue.
Posted Nov 30, 2023 - 06:04 UTC
This incident affected: Web and Mobile Apps (Web Application, Android Application, iOS Application), Platform (API - v1, API - v2, API - v3), Signeasy Integrations (Microsoft Teams Bot, Google Workplace Integration), and Core services (Document conversion, Purchases, Document Uploads).