Major outage - Email Deliverability
Incident Report for Signeasy
Resolved
This issue has been resolved.
Posted Sep 25, 2020 - 15:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2020 - 14:12 UTC
Investigating
We are currently experiencing email deliverability issue and it is being investigated.
Posted Sep 25, 2020 - 07:23 UTC
This incident affected: Core services (Email Delivery).