Our system is under scheduled maintenance from 5:30 PM to 7 PM PST.
Incident Report for Signeasy
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 03:21 UTC
Update
We are continuing to investigate this issue.
Posted Jan 07, 2021 - 02:31 UTC
Investigating
Our system is under scheduled maintenance from 5:30 PM to 7 PM PST.
Posted Jan 07, 2021 - 01:46 UTC
This incident affected: Platform (API - v1, API - v2), Web and Mobile Apps (Web Application, Android Application, iOS Application), Signeasy Integrations (Microsoft Teams Bot), and Core services (Email Delivery, Document conversion).