Partial outage - Accessing the web application and the website.
Incident Report for SignEasy
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 20:52 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 13, 2020 - 20:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2020 - 14:28 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 13, 2020 - 14:26 UTC
Investigating
Accessing the web application and the SignEasy website is operating in a degraded fashion for a fraction of users. We are looking into it.
Posted Oct 13, 2020 - 14:00 UTC
This incident affected: Web and Mobile Apps (Web Application) and Website.