Partial outage - Email Deliverability
Incident Report for SignEasy
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 10:10 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 29, 2020 - 10:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2020 - 23:22 UTC
Investigating
We are currently experiencing delay in email deliverability. This is being investigated.
Posted Sep 28, 2020 - 20:19 UTC
This incident affected: Core services (Email Delivery).