Service outage on May 24th, 2021
Incident Report for Signeasy
Postmortem

What went wrong and when did it happen?

On 24th May 2021 we experienced a full system outage starting from 8:30 AM CT to 9:00 PM CT. During this time you may have not been able to perform any action on the Signeasy WebApp, Mobile Apps (iOS and Android), API endpoints, or any of our integrations. The systems were fully restored at 9:00 PM CT.

Why did it happen?

During the course of regular system maintenance, our cloud service provider experienced a database outage. Unforeseen challenges occurred while shifting from the primary to backup databases and led to a longer-than-anticipated outage.

How would you have been affected?

  1. Transaction data
    • During a brief period (approximately 20 minutes; from 8:30 AM to 8:50 AM CT), there may have been transaction data inconsistencies. Once the full outage was detected, we halted incoming traffic to prevent further data inconsistencies.
  2. Document data
    • The storage infrastructure was unaffected and therefore there should have been no impact on your saved documents.
    • There may be some metadata inconsistencies, and if that is the case, we recommend repeating the associated actions (signing documents, requesting signatures, etc.)
    • Further investigation will determine with certainty whether any loss of document data occurred and we will update users once completed for web, mobile and API usage.
  3. Billing and Subscriptions
    • Billing systems were unaffected, so if your account was due for renewal yesterday, it would have been processed successfully.
      If you notice any billing-related discrepancies, please contact us immediately.

The bottom line

We apologize for the inconvenience caused and thank you for your patience. The system is now fully restored. Please re-attempt any document transactions attempted during the outage at this time. If you are unsure about the status of any document transactions attempted around the time of the outage, please check with the document/request recipient or contact our support team.

If you have any questions, please reach us out at support@signeasy.com

Posted May 27, 2021 - 08:04 UTC

Resolved
This incident has been resolved.
Posted May 25, 2021 - 02:38 UTC
Investigating
We're experiencing a service outage. Our team is investigating the issue on priority. Sorry for the inconvenience.
Posted May 24, 2021 - 14:11 UTC
This incident affected: Web and Mobile Apps (Web Application, Android Application, iOS Application), Platform (API - v1, API - v2), Signeasy Integrations (Microsoft Teams Bot, Google Workplace Integration), and Core services (Email Delivery, Document conversion, Purchases).