Scheduled Maintenance in progress. (1:30 AM - 2:30 AM UTC)
Incident Report for Signeasy
Resolved
This incident has been resolved.
Posted Feb 17, 2024 - 02:23 UTC
Update
We are continuing to investigate this issue.
Posted Feb 17, 2024 - 02:22 UTC
Investigating
Our scheduled maintenance window for database migration has begun. We are currently migrating our database services.

Services are unavailable during this process. The estimated completion time is 2:30 AM UTC. Stay tuned for updates!
Posted Feb 17, 2024 - 01:35 UTC
This incident affected: Web and Mobile Apps (Web Application, Android Application, iOS Application, Reports), Platform (API - v1, API - v2, API - v3), Signeasy Integrations (Microsoft Teams Bot, Google Workplace Integration), and Core services (Email Delivery, Document conversion, Purchases, Document Uploads).