Major outage - Importing of non-pdf fails
Incident Report for Signeasy
Resolved
This incident has been resolved.
Posted Jun 21, 2021 - 03:20 UTC
Investigating
We're experiencing issues with importing non-pdf documents into SignEasy. We are looking into this issue on a higher priority.
Posted Jun 21, 2021 - 02:16 UTC
This incident affected: Core services (Document conversion).