With the Google Integration, we're having trouble importing documents and signing them.
Incident Report for SignEasy
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 22:12 UTC
Investigating
With the Google Integration, we're having trouble importing documents and signing them. We're looking into it right now.
Posted Mar 26, 2021 - 03:19 UTC
This incident affected: SignEasy Integrations (Google Workplace Integration).