Slowness in loading the application

Incident Report for Signeasy

Resolved

This incident has been resolved.
Posted May 25, 2021 - 17:48 UTC

Investigating

You may experience slowness in the service. We are adding more capacity to our infrastructure and improving our overall service. We appreciate your patience and understanding.
Posted May 25, 2021 - 16:28 UTC
This incident affected: Web and Mobile Apps (Web Application, Android Application, iOS Application), Platform (API - v1, API - v2), and Signeasy Integrations (Microsoft Teams Bot, Google Workplace Integration).